Joomla 2.5'e Yükseltme ve Göç Hakkında Merak Edilenler

Bu habere oy verin
(3 oy verilmiş)

Joomla 2.5 Göç ve Yükseltme Güncelleme Hakkında Merak Edilenler

Joomla kullanıcılarının merak ettiği soruların başında, "Joomla 2.5 serisine geçmeli miyim" ve "eklentilerim Joomla 2.5 ile uyumlu mu" ya da şöyle diyelim, "Joomla 2.5 uyum sorunları yaşayacak mıyım" soruları geliyor. Genel olarak ilk iki sorunun cevabı evet iken üçüncü sorunun cevabı ağırlıkla hayır olur. Bununla birlikte projesi Nisan 2012'den sonra yayında bulunmayacak kimselere Joomla 2.5'e geçmekle uğraşmaması da önerilebiliyor. Bazı süreli projeler dışında bu pek düşünülecek bir ihtimal değil.

Eğer devam edecek bir projeniz varsa 2.5 serisine geçmelisiniz. Tabii bazı noktalara dikkat etmek gerekiyor. Mesela eski Joomla siteniz için bazı uygulamalar yazdırdıysanız ya da kod düzenlemeleri yaptıysanız, çekirdek kodlara müdahale ettiyseniz, eski eklentiler kullandıysanız, bunların durumunu gözden geçirmeniz gerekli. Bunlarla ilgili detayları forumumuzda soruturabilirsiniz. Ancak kılavuz olacak bir kaç kısa cevap verelim;

Joomla 1.5 Eklentileri ve Temaları Joomla 2.5 ile Uyumlu mu?

Hayır

Joomla 1.6 ve Joomla 1.7 Eklentileri ve Temaları Joomla 2.5 ile Uyumlu mu?

Şartlara bağlı. Bu eklenti ve temalar en düşük Joomla 1.6 için özel olarak kodlanmışsa, en az Joomla 1.6 Native etiketi taşıyorsa, en azından Joomla 1.6 ile tam uyumlu kodlanmış ise evet; Joomla 2.5 ile de sorunsuz çalışacak. Hem Joomla 1.5 hem Joomla 1.6 ya da 1.7 ile çalışacak şekilde düzenlenmiş bazı eklentilerin bir kısmı çalışabilir ama pek güvenmemek lazım.

O zaman sorun yaşamamak için en azından Joomla 1.6 artık olmadığı için Joomla 1.7 ile tam uyumlu sitemiz ve uygulamalarımız olmalı. Bu durumda sorunsuz şekilde Joomla 2.5'e geçebiliriz.

Joomla 2.5'e Yükseltebilir miyim; Göç Edebilir miyim?

Kesinlikle evet! Joomla 1.7 kullanıcılarının çoğu Joomla 2.5 serisine yönetim merkezindeki Güncelle alanı altından tek tıkla geçebilir. Bu, Joomla 1.6 ve 1.7 serisinin kendi içinde sürüm yükseltmesi ile aynı işlemdir. Tabii sunucu altyapısına ve zaman zaman uzak sunucuda olabilecek sorunlar sebebiyle büyülk boyutlu paketlerin çekilip kurulması sorun olabilir. Bu durumda tek tıkla güncelleme yapılamayabilir. O zaman güncelleme için verilen ek paketin eklenti şeklinde kurulması yeterli olur. Bu çoğunlukla daha sorunsuz bir yöntemdir.

Zaman açısından önemli olduğu için kaleme aldığım bu yazıyı, Joomla projesinin öne çıkan isimlerinin yaptığı bir uyarıyla sonlandırmak istiyorum:

Henüz Joomla 2.5 serisine yükseltme yapmamış olan kullnıcıların, bazı hataların giderildiği Joomla 2.5.1 sürümünü beklemelerini öneriyoruz. Joomla 2.5.1 sürümünde, yükseltme ve yükseltme sonrası karşılaşılan bazı sorunlar giderilmiş olacak.

Joomla Portalında ayrıca bu konuyla ilgili olarak yakında yayına girecek yazılar:

  • Joomla 2.5 Kurulum
  • Joomla 2.5 Yeni Özelliklerin İncelemesi (Anlatım Yazı Dizisi)
  • Joomla 2.5 Serisine Göç, Yükseltme, Güncelleme Yöntemleri
  • Joomla 1.5 Sürümlerden Joomla 2.5 Serisine Yükseltme (Göç)
  • Joomla 1.0 Sürümlerden Joomla 2.5 Serisine Yükseltme (Göç)
  • Joomla 2.5 Sürüm Güncellemesi

Aytuğ AKARAytuğ Halil AKAR
2005 yılında Mambo ile tanıştı ve en büyük proje sitesini HTML'den Mambo'ya aktardı. Joomla!'ya Mambo'dan göçü anlatan ilk Türkçe kaynağı oluşturması ve Joomla Partnerliği'nde Türkçe çevirileri ile tanındı. 2006 Aralık ayında bir grup arkadaşıyla CMSTÜRK'ü kurdu, aynı ekip ile 2008 yılında Joomla Kitabını yazdı, 2010 yılında Joomla Portalı'nın temellerini attı. 2012'de Joomla Derneği Kurucu Yönetim Kurulunda Başkan olarak yer aldı. HTML, CSS, PHP biliyor, Notepad++ ve Firewoks kullanıyor. Uluslararası faaliyet gösteren bir organizasyonda görevli. Evli, baba, Uluslararası İlişkiler AÖ öğrencisi, Joomla Profesyoneli.

yazarın diğer yazıları >>

Joomla! Community